Internet Service Daemon (inetd)

The client-server model describes the communication process between two computers or programs.
The client system makes a service request to the server system, then the server system fulfills the request.
Although programs can use the client-server model internally in a single computer, the model is more widely used across a network.
The client-server model provides a way to distribute services efficiently across multiple locations on a network.

The client-server model describes network services and the client programs of those services.


Client Processes

The client is a host or a process that uses services from another host or program, known as a server.


Server Processes

The server is a host or a process that provides services to another program
known as a client.
Client-server computing is a key factor in supporting network computing



Starting Server Processes

Internet Service Daemon (inetd)

The inetd daemon is a special network process that runs on each system and starts server processes that do not automatically start at boot time
The inetd daemon is the server process for both the standard Internet services and Sun Remote Procedure Call (Sun RPC) services

Network services can be independently enabled or disabled using the inetadm command.


# inetadm    ==> to list the current state of all network facilities


Note – When a network service is affected, any related services are also affected. By disabling one service, a number of other services may become unavailable.


# inetadm | grep telnet        ==> to view if telnet is enabled or not

# inetadm -d telnet        ==> to disable the telnet facility

# inetadm | grep telnet

# inetadm -e telnet        ==> to enable the telnet facility

# inetadm | grep telnet

# inetadm -l telnet        ==> to list the details about telnet



Network Ports

Network ports help transport protocols to distinguish between multiple service requests arriving at a given host computer
The TCP and UDP transport protocols identify ports using a positive integer between 1 and 65535, which is called a port number.
Network ports can be divided into two categories, well-known ports and ephemeral (short-lived) ports.

If a port number is not pre-assigned, the operating system allows an application to choose an unused port number.

A client often communicates with a server through a well-known port.

Well-known ports are stored in the /etc/inet/services file.


# grep telnet /etc/inet/services    ==> to view the well-known port of a
                        specific service

# grep mail /etc/inet/services



Starting RPC Services

RPC services are assigned a unique program number by the programmer when they are written.
The RPC services are not typically assigned to well-known ports.
RPC services started at boot time with startup scripts run on available ports above 32768.

The rpcbind process associates RPC program numbers with port numbers.

# grep rpcbind /etc/services



Listing Registered RPC Services

syntax: rpcinfo -p [ host ]

# rpcinfo -p    ==> to list all services registered with rpcbind process

   program vers proto  port service
    100000    4   tcp   111 rpcbind
    100000    3   tcp   111 rpcbind
    100000    3   udp   111 rpcbind
    100000    2   udp   111 rpcbind
    100232   10   udp 32772 sadmind
    100083    1   tcp 32771


       
Deleting RPC Service Registration

syntax: rpcinfo -d prognum versnum

# rpcinfo -d 100012 1     ==> This command unregisters the RPC service with                     program number 100012 and version number 1.

                The deleted RPC service that uses program number
                100012 is sprayd.


To register the sprayd service again, restart the inetd daemon as follows:

# svcadm disable svc:/network/rpp/spray:udp
# svcadm enable svc:/network/rpp/spray:udp


Note – When using the rpcinfo -d command to unregister an RPC service, the RPC service can be identified using either the service name or the program number.

The Network File System (NFS) is a client-server service

The Network File System (NFS) is a client-server service that lets users view, store, and update files on a remote computer as though they were on their own local computer.


# vi /etc/dfs/dfstab        ==> to share local resources

# share [-F fstype] [ -o options] [-d "<text>"] <pathname> [resource]
# .e.g,
# share -F nfs -o rw=engineering -d "home dirs" /export/home2

share -F nfs -o ro              -d "Shared data files"  /usr/local/data
share -F nfs -o rw,root=sys-01  -d "Database files"     /rdbms_files


Note – If svc:/network/nfs/server service does not find any share commands in the /etc/dfs/dfstab file, it does not start the NFS server daemons.


# cat /etc/dfs/sharetab        ==> to view local resources currently shared

# cat /etc/dfs/fstypes        ==> to view a system’s distributed file
                    system types

# cat /etc/rmtab        ==> to view file systems remotely mounted by
                    NFS clients
sys-03:/usr/local/data
sys-02:/export/config
#ys-02:/export/config



Managing the NFS Server Daemons

# svcadm enable svc:/network/nfs/server        ==> to start the NFS server
                            daemons

Note – If the svc:/network/nfs/server service does not find any share commands in the /etc/dfs/dfstab file, it does not start the NFS server daemons.


# svcadm disable svc:/network/nfs/server    ==> to stop the NFS server
                            daemons



NFS Server Commands

share    Makes a local directory on an NFS server available for mounting. It         also displays the contents of the /etc/dfs/sharetab file.

unshare        Makes a previously available directory unavailable for             client side mount operations.

shareall    Reads and executes share statements in the /etc/dfs/dfstab             file.

unshareall    Makes previously shared resources unavailable.

dfshares    Lists available shared resources from a remote or local NFS             server.

dfmounts    Displays a list of NFS server directories that are currently             mounted.



Configuringthe NFS Server for Sharing Resources

syntax: share [ -F nfs ] [ -o options ] [ -d description ] [ pathname ]


# share -o ro /usr/local/data    ==> to share a file resource


# share -F nfs -o ro directory    ==> restricts access to NFS-mounted
                    resources to read-only access


# share -F nfs -o ro,rw=client1 directory   ==> Restricts access to NFS
                        mounted resources to read-only
                        access; however, the NFS server
                        accepts read & write requests
                        from client named client1.

# share -F nfs -o root=client2 directory    ==> Allows the root user on the
                        client named client2 to have
                        superuser access to the NFS
                        mounted resources

This command shares the directory to the four named hosts only. The hosts, client1 and client2, have read-only access. The hosts client3 and client4 have read-write access. The root user from host client4 has root privilege access to the shared directory and its contents.

# share -F nfs -o ro=client1:client2,rw=client3:client4,root=client4 directory


# share        ==> to display a list of all currently shared file resources



Making File Resources Unavailable for Mounting

syntax: unshare [ -F nfs ] pathname

# unshare /usr/local/data    ==> to make the /usr/local/data directory
                    unavailable for client-side mount
                    operations



Sharing and Unsharing All NFS Resources

shareall [ -F nfs ]

unshareall [ -F nfs ]


# shareall    ==> to share all resources listed in /etc/dfs/dfstab file

# unshareall    ==> to unshare currently shared file resources listed in
            /etc/dfs/sharetab file



Displaying Currently Shared NFS Resources

dfshares [ -F nfs ] [ host ]

# dfshares    ==> to display the resources currently being shared by the
            local server

# dfshares sys-01    ==> to display resources shared by another server

# share        ==> to display a list of all currently shared file resources


Displaying NFS Mounted Resources

dfmounts [ -F nfs ] [ server ]


# dfmounts    ==> to display remotely mounted NFS resource information

RESOURCE   SERVER PATHNAME         CLIENTS
  -        sys-02 /usr/local/data sys-03



Managing the NFS Client

Managing the NFS Client Daemons

# svcadm restart svc:/network/nfs/client    ==> to start NFS client
                            daemons

NFS Client Commands

# dfshares servername

# mount

# umount

# mountall

# umountall


Configuring the NFS Client for Mounting Resources

# dfshares sys-01    ==> to list the resources of an NFS server


Mounting a remote file resource

mount [ -F nfs ] [ -o options ] server:pathname mount_point

# mount sys-02:/rdbms_files /mnt    ==> to mount a remote file resource

# mount -o ro sys-45,sys-43,sys-41:/multi_homed_data /remote_shared_data


In the above example, if sys-45 server is unavailable, the request passes to
the next server on the list, sys-43, and then to the sys-41 server. This process works if the resource mounted from all of the servers is the same.



Unmounting a remote file resource

umount server:pathname or mount_point

# umount /rdbms_files        ==> to unmount a remote file resource



Mounting & Unmounting remote file resources only (resources listed in the
/etc/vfstab file with a mount at boot value of yes)

mountall -r [ -F nfs ]

umountall -r [ -F nfs ]

# mountall -r        ==> to mount all remote file resources only

# umountall -r        ==> to unmount all remote file resuources only


Note – Use the -F FSType with the mountall and umountall commands to specify FSType as the file system type. You do not have to specify the -F nfs option, because NFS is listed as the default remote file system type.


Mounting Remote Resources at Boot Time

Enter appropriate entries in the client’s /etc/vfstab file to mount remote file resources at boot time

# vi /etc/vfstab

#device              device       mount         FS   fsck mount   mount
#to mount            to fsck      point         type pass at boot options
#
sys-02:/usr/local/data       - /usr/remote_data  nfs   -   yes    soft,bg


bg|fg        During an NFS mount request, if the first mount attempt             fails, retry in the background or foreground.
             
        The default is to retry in the foreground.

soft|hard    When the number of retransmissions has reached the number             specified in the retrans=n option, a file system mounted with             the soft option reports an error on the request, and stops             trying. A file system mounted with the hard option prints a             warning message and continues to try to process the request.

        The default is a hard mount.
       
        Although the soft option and the bg option are not the             default settings, combining them usually results in the         fastest client boot when NFS mounting problems occur.



Enabling NFS Server Logging


Note – Server logging is not supported in NFS version 4.


Create tag entries for each of the server’s shared resources.
The global tag defines the default values.


# cat /etc/nfs/nfslog.conf        ==> to configure NFS log paths

# NFS server log configuration file.
#
# <tag> [ defaultdir=<dir_path> ] \
#       [ log=<logfile_path> ] [ fhtable=<table_path> ] \
#       [ buffer=<bufferfile_path> ] [ logformat=basic|extended ]
#
global  defaultdir=/var/nfs \
        log=nfslog fhtable=fhtable buffer=nfslog_workbuffer


To easily identify the log files for different shared resources, place them in
separate directories. For example:

# cat /etc/nfs/nfslog.conf

# NFS server log configuration file.
#
global defaultdir=/var/nfs \
         log=nfslog fhtable=fhtable buffer=nfslog_workbuffer
public defaultdir=/var/nfs/public \
         log=nfslog fhtable=fhtable buffer=nfslog_workbuffer


Note – Create /var/nfs/public directory before starting NFS server logging.


Initiating NFS Logging

1. Become superuser.


2. Optional: Change the file system configuration settings.
In the /etc/nfs/nfslog.conf file, either:

        Edit the default settings for all file systems by changing the data
        corresponding to the global tag.
   
        Add a new tag for the specific file system.
  
If you do not need these changes, do not edit this file.


3. Edit the /etc/dfs/dfstab file to add an entry for file systems for which
   you want to enable NFS server logging.

   Either:
    
        Use log option without specifying a tag - to use the global tag as
    default.

        Specify a tag - with the log=tag option

share -F nfs -olog /export/sys44_data
share -F nfs -olog=public /export/sys44_data


4. Check that the NFS service is running on the server, if not start it.

# svcadm enable svc:/network/nfs/server


5. Run the share command to verify that the correct options are listed.

# share


6. If you add additional entries to /etc/dfs/dfstab file, share the file
   system by rebooting the system or entering the shareall command.

# shareall

Sun solaris10 Installation with help of vitrual Box


Sun solaris10 Installation with help of vitrual Box



Step by step method to install solaris 10 operating system

1.Install virtual Box in your System available for window , linux , mac .

open Source software . so no need to pay money .support open source software and contribute your skills .


www.virtualbox.org/

2. Then follow reaming steps in above video

Basic Commands (Unix)

General Unix Commands :




CommandExampleDescription
1.     lsls
ls -alF
Lists files in current directory
List in long format
2.     cdcd tempdir
cd ..
cd ~dhyatt/web-docs
Change directory to tempdir
Move back one directory
Move into dhyatt's web-docs directory
3.     mkdirmkdir graphicsMake a directory called graphics
4.     rmdirrmdir emptydirRemove directory (must be empty)
5.     cpcp file1 web-docs
cp file1 file1.bak
Copy file into directory
Make backup of file1
6.     rmrm file1.bak
rm *.tmp
Remove or delete file
Remove all file
7.     mvmv old.html new.htmlMove or rename files
8.     moremore index.htmlLook at file, one page at a time
9.     lprlpr index.htmlSend file to printer
10.   manman lsOnline manual (help) about command


Upcoming Solaris 11 OS Features

Oracle Solaris 11 Express includes :



  •   GNOME Desktop Environment, 
  • GNU tools, 
  •  a network-based software management system.

 The OS also includes state-of-the art features



  • Oracle Solaris ZFS file system,
  •  Oracle Solaris Dynamic Tracing (DTrace) framework,
  •  containers for running applications in protected environments,
  •   advanced network virtualization capabilities.
If you Like to download solaris 11 . please click below link

using reconfigure command to system reboot

reconfigure command

 some time for an long time without rebooting solaris system or important hardware changes need reboot important for proper working . The following  steps

bash #> touch reconfigure 

using touch command to create   empty directory .
directory name  should be reconfigure .(compulsory)
after creating

bash # > ./reconfigure 
bash # > init 6  
system reboot .
after login and finally reconfigure directory deleted automatically by solaris OS . all new drivers attached successfully ..

Devfsadm command to reconfigure hardware Devices without rebooting and path_to_instance

Most of real time application runs 24 / 7 . Hence no need to power off machine in case of new hardware adding like RAM , Hard disk . Hot plug-able devices

solaris 10 use following command

devfsadm ---------- command to reconfigure new attached devices.

devfsadm -C     command to write new changes  in library files ..

most of the hardware files associated with

bash > etc/path_to_instance 

contains all hardware devices with Instances names..